Version 2.8.2
     
Student Course Requests
     

Browser Requirements

The minimum browser requirements for the txSuite applications are as follows:
  • Internet Explorer 8.0 or later
  • Mozilla Firefox 7.0 or later
  • Safari 5.0 or later
  • Chrome (the latest version)